Menu Close

Run Failure: "Sequence contains no elements"

Syncrosim Forums ST-Sim & State-and-Transition Simulation Models Run Failure: "Sequence contains no elements"

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #1674

    I’ve been running through the example scenarios in Exercise 10 of the ST-Sim course handbook using resampled versions of the original raster data (i.e., I reduced the cell size/increased the resolution of the original data). This has not been a problem for any scenarios except for the restoration of large patch edges scenario. When I try to run this scenario with the resampled data I receive the run failure message “sequence contains no elements.” I tried converting the input rasters from float to integer format (with multiple different values for “NO_DATA”), but got the same result. The scenario runs fine with the original raster resolution.

    The problem seems to be related to the cell size. Any ideas?

    Thanks in advance!


    Hi Brian,


    This is a known bug in version 1.4 of ST-Sim associated with prioritizing large patche edges for transitions when area targets are used.  The crash is incosistent and does not always occur; but it does often.  It will be fixed in the upcoming version (1.5) of ST-Sim.  We hope to get a release out by early November.





    Hi Leonardo,

    Thanks for the reply. I’ll watch for the release of the new version!


Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.