Menu Close


Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • in reply to: Errors running the Omniscape example #21545

    Hi Dave,

    We just created a package release for omniscape to fix the issue you were having.

    You can update to the new package version in SyncroSim by selecting File, Packages. Then, click on the Update… button, select omniscape; and click OK. Create a new library from the template library and when prompted to overwrite the conda environment, select Yes.

    Now, you should be able to run the package with the Use Conda option selected.


    in reply to: Errors running the Omniscape example #21517


    Sorry for the wait, we were working on isolating and reproducing the issue.

    The issue is generated when importing one of the pysyncrosim dependencies, rasterio. We are submitting an issue on the rasterio GitHub repository to get the bug resolved.

    In the meantime, you can run omniscape without using conda and installing the required dependencies on your own. To do so, open the Library Properties by right-clicking on the Library name (Omniscape Example) and select Properties from the context menu. Navigate to the Advanced tab and at the General datasheet deselect the option “Use Conda”. Next, you will need to install python, pysyncrosim, pandas, rasterio and gdal, if they are not installed on your computer. Then, before running omniscape, you will need to specify the path to the python executable file. To do so, go to the Library Properties again. Under the Python Configuration tab, select Run directly and use the browse button to navigate to where your python.exe file is.

    Alternatively, if you’d like to use the conda environment, you will need to modify the Windows PATH variable. Certain programs, when installed or configured, add a “.” to the Windows PATH. When running the omniscape package, the import of the rasterio package loops through the directories in the PATH and tries to add this “.” to its search path using the os.add_dll_directory() function. This leads to the error because “.” is an invalid parameter for the os.add_dll_directory() function. You can read more about this error and check the progress of its resolution at

    If you still want to run omniscape using conda you will need to remove certain programs from your Windows PATH variable. To check which programs are adding “.” to the PATH, you can run os.environ[“PATH”] in python and do a search for all “;.”. Any folders that come before this “;.” are adding the “.” to the PATH.


Viewing 2 posts - 1 through 2 (of 2 total)