Menu Close

Enabling long path support in Windows

Syncrosim Forums SyncroSim – General Questions and Answers Enabling long path support in Windows

Viewing 1 post (of 1 total)
  • Author
  • #22144
    Katie BirchardKatie Birchard

    Issue: When running a simulation in SyncroSim, it fails with the following error message:

    [Failure] Could not find a part of the path 'C:\Users\Administrator\reallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallyreallylongpath\stsim\templates\spatial-example.ssim.input\Scenario-16\stsim_InitialConditionsSpatial\initial-sclass.tif'.

    Solution: SyncroSim fails to find the path to the external file because the filepath is greater than 260 characters. In Windows 10 and 11, long path support is not enabled by default. To explicitly enable long path support in Windows 10 and 11, follow these steps:

    1. Ensure that you have Administrative Rights to make changes to your operating system.
    2. Click on the Start menu and type RegEdit. It will return the Registry Editor. Open it.
    3. Windows will ask if you want to allow the program to make changes to your computer. Click Yes.
    4. In the left panel of the Registry Editor window, navigate to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > FileSystem.
    5. In the right panel, find the LongPathsEnabled entry. Right-click and select Modify….
    6. This will bring up a window with the title Edit DWORD (32-bit) Value. Under Value data, change it from 0 to 1 and press OK.

    You should now be able to run your simulation in SyncroSim without the above error.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.